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1

Reusing Your Data in OpenLAB CDS
ChemStation Edition with OpenLAB
Data Store or OpenLAB ECM

Sequence Data Stored in Result Sets 6

Transferring ChemStation Data to OpenLAB Data Store or OpenLAB
ECM 7

This chapter describes a manual procedure for transferring
ChemStation Sequences that were stored in containers (now
called result sets), from a ChemStation file system into
OpenLAB CDS ChemStation Edition with Data Store or ECM.

These instructions support the transfer of data from ChemStation
B.04.03 SP1 to OpenLAB CDS ChemStation C.01.04 or higher.

Agilent Technologies
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Sequence Data Stored in Result Sets

In order to strengthen the association between data files and
methods, the usage of result sets has been introduced with
ChemStation B.02.01 (result sets have been called sequence
containers then). If you use a central data storage system
(OpenLAB ECM or OpenLAB Data Store), the complete result
set (sequence/methods/data files/report templates) is
transferred to the central repository as one entity.

<data_filel>.D
<data_file2>.D '[ P

<data_filed=.0

Sequence Method
<geq_name>.5
<geq_name>B

<geq_name>.log

Report Templates
<templ_name> ROL

Figure1  Sequence Acquisition with Unique Folder Creation ON

The methods in the folder Chem32\1\methods serve as master
methods. They remain unchanged during acquisition and data
analysis.

Similarly, the sequences in the folder Chem32\ 1\sequence serve
as sequence templates that can be used to rerun (but not
reprocess) a sequence several times.

Report Templates in the folder Chem32\repstyle serve as a
starting point for developing your own report templates.

If your data is not in this format, Agilent recommends changing your
configuration now, to be ready to migrate easily in the future.

See “Step 1 —Verify Containers are in Use.” on page 7, for more details on
this.
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Transferring ChemStation Data to OpenLAB Data Store or OpenLAB ECM

Requirements

The user who will carry out this transfer must be part of the
Local Administrator group.

The user should have administrative privileges in ChemStation
and in OpenLAB Shared Services (the Everything privilege in
OpenLAB Control Panel) so he can edit the method and
sequence data path, select the ECM or Data Store path in the
transfer settings, and create and configure instruments in
OpenLAB Shared Services.

The data to be transferred must be stored in containers (result
sets).

Step 1 — Verify Containers are in Use.

Only data stored in a container (result set) will transfer to Data
Store or ECM.

Before continuing, verify that the data being transferred is in a
container. Data in containers will look similar to the screen
capture below. Notice that all the data files, the sequence file,
and the methods used in the sequence are grouped in a single
folder. This folder, known as the container in ChemStation
B.04.03, is now called the result set.

If you see the data is not in this format, Agilent recommends changing
your configuration now, to be ready to migrate easily in the future.

For old data that is not in a container, create one as described in step
2.

J Chem32 o Name Date medified Type Si

01

DATA
DEMO

_001_001B0101.D
| _002_002B0201.D
| _003_003B0301.D

212:46 PM
212:46 PM
212:46 PM

File folder
File folder

File folder

. ETG90814
. JV20111103B 2011-11-03 13-2

. DEF_GC.M 212:46 PM File folder

Result Set for the sequence

4% | CheckSum.ini 212:46 PM Configuration sett...
“ S e” . MyS =
named My A yooiq:;n;;ml 5 || container.metadata METADATA File
T ' @ METHODS.REG 2146 PM Registration Entries
. _002_002B0201.D :
TR | MY SEQUENCE.B 21246 PM  BFile
) EJEFiGC o ' | MY SEQUENCE.LOG 212:46 PM Text Document
- = E | MY SEQUENCE.S 21246 PM  SFile

gci
methods

212:46 PM !
212:46 PM

VL File
File

Fa R R R0 Ra P ba R R R Ra F
g
2 2 2 3 r

4
4
4
4
4
212:46 PM
4
4
4
4
4
4

|| RESS0LV.macaml

|| sequence.acaml

sequence
TEMP
VesCache

For more details on ChemStation data Structure please refer to
the OpenLAB CDS ChemStation Edition Concepts and
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Workflows guide (M8301-90015).

Step 2 — Create a Result Set for Results that are not in a Container.

Use the Result Set Migration screen in ChemStation to make
containers (result sets) for the data to be uploaded to Data
Store or ECM.

Only use this procedure if you are certain about the sequence and method that
was used to produce the data.

1 From the Data Analysis view of the OpenLAB ChemStation,
select Sequence > Result Set Migration... to open the Result Set
Migration dialog.

| Result Set Migration =

To migrate data to a resull set, select sequence template, method path, date seurce and destination directories

T Select sequence template:
[I)  Select method path
&  Selectsource
&  Select destination

Messages and warnings:
Start ] [ Close ] [ Help

2 Navigate to, and select the sequence template from the
ChemStation B.04.03 backup data acquired for that
instrument folder.

If you do not know which sequence was used, please refer to
*.log in data folder.

This figure highlights the log file (Test3.1og) in the Test3 data

folder:
= |
@u w| L ¢ Chern32 » 1 b LC DataBackup » DATA » Tastd » - |y | Fecrch Testa
Organize = Open - Print Burn Pl Frdder = T
— Harme Date modified Type
B Desktop 001-0101.0 der
& Dosamloads 002-020L.0 der
L Recent Places 003-030L0 File Folder
_| Dietmarted Test Document
w4 Libraries | TESTAER & File
Text ok ment

= Documnents | TESTALOG

This figure shows the Test3.log file opened in Notepad, with
the name of the sequence file highlighted:

8 Reusing B.04.03 ChemStation Data in OpenLAB CDS



Reusing Your Data in OpenLAB CDS ChemStation Edition with OpenLAB Data Store or OpenLAB ECM

@u\v‘,vlj % Chem3t ¥ L b LG Dntafackup + DATA b Teitd b I I | pr——
O — =
Test3.LOG ———— 1 TeSTaLo6- Notepsd
] File Edit Format ‘iew  Help
i 0 ldab 4ff2%aee o
42008 1 G42B4EI0EABCIOO00 - Run Q%1030 07 03012
0 ldab 4fF2Saed u]
o 42906 1 G4284B:DEABCS0CDD - Detactor: Prepare 09:10:30 07,/03/12
1 0 ldab 4FF20aa? o
42908 1 G42B48:0EABCS0000 - pETecTor: tdle 02:10:31 07,05,/12
0 ldaa 4ff2%hie
o GA2908 1 G4283a:0EABCIO0ND = POSTrUN 02:12:30 07/03/12
67 dle2 dﬂ:Z‘?hEZ 1]
Method nstrument run complated 0912534 07703702
i 70 dled Jf‘FZQ‘hEE o
CF Macro z‘lng rawdata Q03-0301.0 091234 07/05,/12
67 41.&2 41‘1“2‘%6%’
3h L AFFZSEQ?E! cagp'lmed 0212137 07/03,/12
4da 41
seque“ce used SEQUENCE acouisition For|resrs.s cmgleredl 0212 3T 0703,12
m| 43e 4lsl 4ff2ghes o
| sequence TESTS. 5 completed Q212137 0770312
-

3 Select the Method folder from the ChemStation B.04.03
backup location.

4 Select the source folder from the ChemStation B.04.03
backup location.

£, Reesuilt Sk Migration

| Broowse For Folder = —

To migrate dafa o aiesuk sef, select sequencd  Sadect the Drata Destination Foldsr

o Select sequence template: C:AChe

L Chern3k =
) Select method paty 50 # i Chern3t new |J
4 51 E
& Selectsowcs C:A\Chf a b o8I,
& Select destination: b Demo
o etead 1
Mesttages el marings! b ) TESTZ_EX8.04.03 2012-07-05 14-43
L ogri
)i WETHODS |
4| ___“_-ili_ | ] 1
Misks: P Fokder [ ook || coe | |-
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b Select the destination folder. Create a new subfolder within
the data folder structure of the upgraded C.01.04 location
and select it as the destination.

6 Click Start.

[ Reault Set Migration ==
To migeate data bo & resdl oot select sequence templste. method path, data source and destination diectonies.
@ Select sequence tenpli CAChem32 T \LC_Diats Baskud SEQUERCENTESTIS [W]
] Select method path: CACkemIZ 1 \LC_Dats Backus\METHOODS
G5 Seectsouce: [ AChem32 T \LC_ Diata Backup DATANTest® [ Bows |
& Selec desinsin CAChemI2_new 1 DT D e Tet3 Browse
Mesage: avd wammngs
S J[ mee [ M ]

7 If the result set migration was successful, an appropriate
message will be displayed as highlighted in the figure below.

" Raault Set Migratian ==
To migrate data bo a resull set, selact sequence template, method path, data scurce and destinafon drectories.
@ Selectsequencetemplte CAChem32\1LLC_Diata Backuph SEQUENCENTES T3S [ Buowa | f
) Selectmethod pathc CAChem3ZA\LC_Diats BackupAMETHOOS
B Selectsouce CAChem 32T \LC_Dals BackushDATANT 0212 [ Buowes | I
& Selectdssingio Biowse
Meseage and waining: I Sucoessluly migrabed hoCA\Chem3E_revAT\DATA\D ala ax Tesld |
St || e [ Hen |

For more information on result sets refer to ChemStation

documentation.
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Step 3 — Manually Transfer Data Into OpenLAB Data Store or OpenLAB

ECM.

1

Setup a client PC with a Data Store or ECM connection.

For ECM, please refer to the ECM Installation Guide.
For Data Store, please refer to the Data Store Installation
Guide.

Create folders for your data, methods, and sequences in
Data Store or ECM.

In the ChemStation Method and Run Control view, browse to
Data Store or ECM > Preferences. In the Preferences dialog:

a Click the Paths tab and enter the paths for Sequence,
Data, and Methods that were used with the ChemStation
file system.

b Click the Transfer Settings tab and select the Import After
Reprocessing check box. Verify that the data transfer path
is set to the correct path.

If the Import After Reprocessing check box is cleared and grayed out in
the Preferences, this option needs to be enabled for the entire workstation
in the ChemStation Administration Tool. This tool is accessible to
administrators (under Start Menu > Programs > Agilent Technologies>
OpenLAB CDS ChemStation Edition).

Add Methods from a ChemStation File System to Data Store or
ECM

1

From ChemStation Explorer, in the Method and Run Control
view, click the Methods tab and then double-click a method
to load it.

Click Data Store or ECM > Save Method.

Browse to a folder created in Data Store or ECM and save
the method.

The method icon in the ChemStation Navigation Pane will
change from [J] to Ll indicating that the method has
been saved to Data Store or ECM.

If the instrument configuration of the method being saved
does not match the current instrument configuration, the
configuration may need to be resolved prior to saving.

Reusing B.04.03 ChemStation Data in OpenLAB CDS 11
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12

Add Sequence Templates from a ChemStation File System to Data
Store or ECM

1

From ChemStation Explorer, in the Method and Run Control
view, click the Sequence Templates tab and then double-click a
sequence template to load it.

Click Data Store or ECM > Save Sequence Template.

Browse to a folder created in Data Store or ECM and save

the sequence template.
The icon for the sequence template will change from 5 to
t% indicating the sequence template has been saved to

Data Store or ECM.

Add Data from a ChemStation File System to a Data Store or ECM
System

For this way of importing data, the Import After Reprocessing check box
must be selected in the Preferences > Transfer Settings dialog or in the
ChemStation Administration Tool.

From ChemStation Explorer, in the Data Analysis view, click
the Data tab.

Double-click data that you want to add to Data Store or
ECM. Please note that only data stored in a container or
result set will be transferred.

Reprocess the data by choosing the Reprocessing Mode and
clicking g (Start Sequence Reprocessing) in the sequence
reprocessing toolset.

Data from the file system will appear in Data Store or ECM.
The sequence icon in the ChemStation Navigation Pane will
change from k&g to i indicating that the sequence has
been saved to Data Store or ECM.

Add Other Files from a ChemStation File System to a Data Store or
ECM System

1

2

In the Method and Run Control view or in the Data Analysis
view, Click Data Store or ECM > Upload Files.

In the Upload file dialog, select the file to upload and the
target folder in Data Store or ECM.

You can add UV-libraries (*.uvl), column databases (*.mdb),
Easy Sequence templates (*.est) or classic report templates
(*.frp).

Reusing B.04.03 ChemStation Data in OpenLAB CDS
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This chapter describes how to move methods, sequence and
data files from a standalone ChemStation Workstation, version
B.04.03 SP1 and SP2, to an OpenLAB CDS ChemStation Edition
Workstation, version C.01.06 when the data is stored in the
container mode.

Also included in this chapter is a list of documents that contain
more details on reusing data.
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Steps to Migrate

14

Manually backup data acquired for all ChemStation B.04.03
SP1 instruments.

Run the Configuration Editor and record the following
details of each configured instrument. You need these
details to reconfigure your instruments in OpenLAB CDS
ChemStation Edition C.01.06.

a Instrument number
b Instrument name
Instrument type

d Connection settings (for example, IP address or GPIB
address)

Uninstall all Add-On Solutions. Refer to the Add-On Solution
manual for specific uninstallation instructions.

Install OpenLAB CDS ChemStation Edition C.01.06. During
the installation, the Master Installer either uninstalls the
previous ChemStation or moves it to a different folder
before installing OpenLAB CDS ChemStation Edition
C.01.06.

If you choose to keep the existing ChemStation folder, the
installed ChemStation files are removed, and all
user-created files are moved to a backup folder, for
example, Chem32_001.

If you choose to create a new folder, the existing folder is
retained with its original name.

To move data which was previously saved in a container
mode, add the path from the ChemStation B.04.03 version to
the new directory/machine by using the Preferences > Path >
Add function.

a In the Data Analysis view, select View > Preferences to
open the Preferences dialog box.

b Click the Paths tab.

¢ Press Add and navigate to the location of the sequence
templates, data, and master methods, that were created
by the ChemStation B.04.03 system. (This could be from
the backup folder of the ChemStation B.04.03 system,
which was prepared before upgrading to C.01.06, or the
backup folder Chem32_001 generated by C.01.06 Master
Installer.)

Reusing B.04.03 ChemStation Data in OpenLAB CDS
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d Click OK.

The selected paths and all the sequence templates, data,
and master methods stored in them are now displayed in
the ChemStation Explorer.

Praferencer E
Paths | Spquence | Signal/Review oplions | Audi Tial | Transfer setings |
Saquerce templales
| CoCheniti_new 1 \SEQLENCE Add,
C\Chem3241ALE_Dale Backupt SEQUENCEY :
[ Ao |
Dala
[:\Cheemid2_peesd \DATAY [ asa. |
CAChem3nWLE_Data BackuphDaTal :
| Femoe
Waster rethod:
| C\Chemaz_ret \METHODS, -
C:Cheem 124 1'LE_Diale Dacku METHODS! :
l Femmos |
[ ok || concel || Hep |

6 Double-click each sequence, one at a time, to load the
associated data files into ChemStation memory, then click
the Start Reprocessing icon to reprocess the data and
generate a C.01.06 ChemStation result set. Please see the
Checksum.ini and Sequence.acaml file for the time stamp to
confirm that the data was reprocessed.

Start Reprocessing icon

Data Analysis
Path identified in step b —=G# Ci\CHEM3Z\1\LC_DATA BACKUFDATA : : _
% BREA_PERCENT SEQ) Overlay Type Line Inj Yial
-4 ESTD_AREA_SEQ =|(|I » ] & 1 1 ¥ial1
-4 ESTD_PERCENT_SEQ [} & z 1|vial 2
-4 1STD_AREA_SEQ B & 3 1| vial 3
-4 15TD_PERCENT_SEQ &l & 3 2| vial 3
- SEQDATA MIG 0| & 3 3 vial 3
---%_Tesn_r{esults.et y —
g TEST2_RESULTSET :
- TEST3 2012-07-04 10-05-27 | [ integration| 2k Calibration [/ Signal [I]
-4 TEST3_RESULTSET " .
- [ Single Runs : I&d @ M | Repart: ! i OWWD1 A, Wavele,., SE1
w7 mERan %
Data |Methods [ VDA &, Wiavelen gth=254 nm (CACHEM3ZY
......... — = =
% Method and Run Control 75_; E E ﬁ
a0-= E E
H £ g
= e g / g
Ei‘ Data Analysis D_;J ) ] A
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Facts to Know for Data Migration

Compatibility of ChemStation Entities

In general, forward compatibility is guaranteed. This means that
it is possible to load methods, sequence templates and data
from previous versions in newer versions. This is especially true
for loading files from any ChemStation rev. B.xx.xx version into
OpenLAB CDS ChemStation Edition rev. C.xx.xx. But there is
no backward compatibility. Once a method or sequence
template has been stored in OpenLAB CDS ChemStation
Edition rev. C.xx.xx, it can no longer be used in a ChemStation
rev. B.xx.xx. The same is true for data. Loading data files from
OpenLAB CDS ChemStation Edition rev. C.xx.xx in
ChemStation rev. B.xx.xx is not supported and could lead to
serious issues with the data files creating wrong or incomplete
results. Therefore Agilent recommends clearly separating
ChemStation rev. B.xx.xx files from OpenLAB CDS
ChemStation Edition rev. C.xx.xx files within ECM to make sure
that files are not loaded in an older version by accident.

Migration of Reporting Templates

Currently there is no migration for old FRP report templates to
the new RDL report template format. Old FRP templates will
continue to work in OpenLAB CDS ChemStation Edition rev.
C.xx.xx, but new RDL templates have to be created from
scratch.

Migration of Classic Methods to RC.net Methods

RC.net methods were introduced in ChemStation rev. B.04.02.
The method migration (migrating classic methods to RC.net
methods) will still work the same way in OpenLAB CDS
ChemsStation Edition rev. C.xx.xx. An RC.net method cannot be
converted back to a classic method.

Estimated Time to Upgrade

16

The estimated time to upgrade from ChemStation B.04.03 SP1
to OpenLAB CDS ChemStation Edition rev. C.xx.xx is
approximately 30 minutes for software upgrade.

Reusing B.04.03 ChemStation Data in OpenLAB CDS
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List of Detailed Documents to Reference

1

Overview of Upgrade procedures:

Please refer to the chapter Overview of the Upgrade
Procedure in the OpenLAB CDS ChemStation Edition
Upgrade Preparation Guide, (M8301-90032,
CDS_CS-Upgrade.pdf on disc 2)

Result Set Migration and more details on ChemStation data
structure:

Please refer to the chapters Result Set Migration and
ChemStation Data Structure in the OpenLAB CDS
ChemStation Edition Concepts and Workflows Guide
(M8301-90015, CDS_CS_Concepts.pdf on disc 2)

Upload and reprocess workflows:

Please refer to the chapter Working with ChemStation and
Central Data Storage in the OpenLAB CDS ChemStation
Edition with Central Data Storage Concepts Guide
(M8301-90083, CDS_CS-with-DataStorage.pdf on disc 2)

Reusing B.04.03 ChemStation Data in OpenLAB CDS 17
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