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This guide has instructions for installing the Agilent Protein and Peptide 
Software. It then guides you through the following steps of verifying the 
primary sequence of chicken lysozyme to illustrate how the software may be 
used:

• Set up the theoretical data file, which includes entering the expected 
sequence, adding disulfide bonds, simulating chemical reduction and 
alkylation, and simulating the tryptic digest. 

• Compare (mass match) this theoretical data file with a results file from a 
previous run and review the results. 

When you are done with this example, you will be more familiar with the 
software and some of its capabilities.

Where to find more information
Use the online help for in-depth information not given in this Quick Start 
Guide. Display online help in any of the following ways:

• Click the Help button in the toolbar.

• Select Help Topics from the Help menu.

• Click the Help button on most dialog boxes to display task-specific help.
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Introduction to Agilent Protein and Peptide Software
Introduction to Agilent Protein and Peptide Software

The protein and peptide software (Peptide Tools) is part of the Agilent G2720 
Bioanalysis software. It is used with Agilent 1100 Series LC/MSD Systems, 
Agilent 1200 Series LC/MSD Systems, and Agilent 6100 Series Single Quad 
LC/MS Systems.

The protein and peptide software performs sophisticated biochemical 
calculations. It can automatically calculate most abundant and average 
molecular weights of proteins, peptides, and other biomolecules.

You can enter the amino-acid sequence of any protein or peptide in the main 
screen and save as a peptide tools data (.PTD) file for future use. This file can 
then be used to process many sample runs. The software also allows you to 
create amino-acid modifications and the different types and locations of links 
and bridges in a sequence.

Agilent Protein and Peptide Software can also be used to simulate protein 
digestion. This simulation creates theoretical data that can then be compared 
to the results of an actual analysis. For example, the software can rapidly 
correlate mass spectral data from a peptide map analysis with theoretical 
peptide digest fragments, and show differences resulting from 
posttranslational modifications, DNA point mutations, or incomplete 
digestion.

The comparison of theoretical data against actual experimental data is called 
mass matching. Mass matching can be performed interactively or it can be 
automated as part of a ChemStation method.

The Isotope Distribution view of the software can be used to graphically 
display the theoretical distribution of the isotopes of a sequence chain or 
fragment. It will also predict the possible charge states and m/z values based 
on the building block composition.

The CID (collision-induced dissociation) view in the software helps you 
confirm the presence and identities of peptides analyzed by mass 
spectrometry. The CID view can be used to predict the fragment ions that may 
be produced by CID of a selected digest fragment or sequence chain in the 
mass spectrometer. You can then compare the predicted fragment ions with 
the fragment ions actually observed. The CID view works well as a tool for 
confirmation.
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Menus and Toolbar
Menus and Toolbar

The following menus options are available in Agilent Protein and Peptide 
Software:

File Menu Edit Menu Operations Menu Options Menu View Menu

New
Open
Save
Save As
_______
Print
Print Setup
Page Setup
_________
Load LCMS Results
___________
Exit
___________
Recently Opened File 
List

Undo
Cut
Copy
Paste
Delete
________
Links
Modifications
Building Blocks
Chain Names
Sample Info
_________
Find
_________
Discard Chain
New Chain

Digest
Global Modifications
Find Matches
Search for Mass

Sequence Display
______________
Automatic Calculations
Calculate Now
___________
Insert from Comp Table

Sequence Chain
Digest Fragments
Summary of All Chains
__________________
Show MS Peak Data
Isotope Distribution
CID
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Menus and Toolbar
The following items are available on the Agilent Protein and Peptide Software 
toolbar:

Button Equivalent Menu Item Button or Information Equiv. Menu Item or Description

File > Open Edit > Find

File > Save Subsequence Search

File > Print Operations > Digest

File > Load LCMS Results View > CID

Edit > Undo Avergage molecular weight

Edit > Cut Options > Calculate Now

Edit > Copy Most abundant molecular weight

Edit > Paste Basis for mass calculation*

*S = Sequence chain, BB = Building block composition table, MF = Molecular formula, 
T = Total of all sequence chains, H = Highlight section of sequence chain
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To install Agilent Protein and Peptide Software
To install Agilent Protein and Peptide Software

If the Agilent G2720 Bioanalysis software is not already installed on your 
system, install it as follows.

1 Verify that ChemStation software is installed before you installing Agilent 
Protein and Peptide Software.

2 Insert the CD-ROM labeled G2720 into the CDROM drive.

3 Click the Start button and select Run.

4 Type x:\setup, where x is the letter of the CDROM drive, and click OK. 

5 Follow the instructions on the screen to install the software.

Start Agilent Protein and Peptide Software
1 Switch to the Data Analysis view in ChemStation software.

2 Select Peptide Tools from the Spectra menu.
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Verifying the primary sequence of chicken lysozyme
Verifying the primary sequence of chicken lysozyme

The example of verifying the primary sequence of chicken lysozyme contains 
the following steps, which are described on the indicated pages of this guide:

• “Enter the sequence” on page 7

• “Add disulfide bonds” on page 8

• “Simulate chemical reduction of disulfide bonds” on page 9

• “Simulate alkylation” on page 9

• “Simulate the tryptic digest and save the file” on page 10

• “Save the file” on page 10

• “Load the results file” on page 11

• “Find the matches” on page 13

• “Review the report” on page 14

• “Review digest fragments” on page 15
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Verifying the primary sequence of chicken lysozyme
Enter the sequence

The expected sequence of amino acids for chicken lysozyme is as follows:

Enter the sequence as follows:

1 Turn Caps Lock on (the sequence must be entered in capital letters).

2 Click between the two boxes in the Sequence Chain text box and begin to 
type each letter of the sequence.
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Verifying the primary sequence of chicken lysozyme
Add disulfide bonds

1 Select Links from the Edit menu to open the Links and Bridges dialog box.

2 Enter 6 in the From index field.

3 Enter 127 in the To index field.

4 Select Cysteine disulfide bond for the Link type.

5 Click the Add button.

6 Repeat steps 2 through 5 for each link in chicken lysozyme (refer to the 
figure shown below).

7 Click OK.

Tip Use the Edit Type button to create a custom link or bridge.
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Verifying the primary sequence of chicken lysozyme
Simulate chemical reduction of disulfide bonds

1 Select Global Modifications from the Operations menu to open the Global 
Modifications dialog box.

2 Select Reduction from the list of available modifications, as shown below.

3 Click OK.

Simulate alkylation
1 Select Global Modifications from the Operations menu to open the Global 

Modifications dialog box.

2 Select Alkylation (iodoacetic acid) from the list of available modifications, 
as shown below.

3 Click OK.
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Verifying the primary sequence of chicken lysozyme
Simulate the tryptic digest and save the file

1 Select Digest from the Operations menu to open the Digest dialog box.

2 Select Trypsin from the list as shown below.

3 Click OK.

Tip Use the Define button to create a custom digest.

Save the file
1 Select Save from the File menu.

2 Type myfile.ptd for File Name as shown below. Be careful not to overwrite 
the example files shipped with the software.

3 Click OK.
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Verifying the primary sequence of chicken lysozyme
Load the results file

In this example, you will be using a results file that was shipped with the 
software. In your own experiment, you would run the actual analysis now and 
then generate the results file.

1 Select Load LCMS Results from the File menu.

2 Select the file lysotryp.res as shown below.

3 Click OK. Your screen should look similar to the example below. The 
theoretical data file you created is displayed on the left; the experimental 
results file on the right.
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Verifying the primary sequence of chicken lysozyme
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Verifying the primary sequence of chicken lysozyme
Find the matches

1 Select Find Matches from the Operations menu.

2 Select Protein Digest from the Match Set list as shown below.

These are the default tests and parameters used for Protein Digest matching:

Digest Fragments Masses are compared to the theoretical digest fragments in 
the .PTD file.

Incomplete Digest Masses are compared to fragment masses, assuming that 
the digest was not complete and that contiguous fragments might still exist.

DNA Point Mutations Masses of existing fragments are adjusted, assuming the 
possibility that single DNA point mutations could have occurred. For example, 
an error in the DNA triplet that encodes for methionine (AUG) could result in 
arginine (AGG) being encoded instead.

BB Modifications Masses of existing fragments are adjusted by any 
modifications that may have been previously assigned to specific building 
blocks (amino acids), and are then compared. In this example, there were no 
modifications assigned.

Tip You can customize these parameters and then resave them in the .PTD file for 
future use.

3 Click OK. A mass match is performed and the data displayed in the results 
window is updated.
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Verifying the primary sequence of chicken lysozyme
• If multiple matches are found within a given test, the closest match (the 
one with the minimum mass difference) is used.

• Masses that have been matched are not considered in subsequent tests.

Review the report
1 Resize the results window as necessary to view the data.

2 Review the results of the mass matching as shown in the example below. 
The first two columns display the retention times and molecular weights of 
the experimental data. The last column displays the calculated molecular 
weights of the theoretical data and the proposed matches. If no match is 
found, this field is left blank.

3 (optional) Use the Print button to print a copy of the report.

4 (optional) Use the Copy button to copy the report to the clipboard.
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Verifying the primary sequence of chicken lysozyme
Review digest fragments

1 Select Digest Fragments from the View menu.

An asterisk ( * ) next to a fragment in the list indicates that the fragment 
was explained (i.e. a match was found). If no asterisk appears next to a 
fragment, then no data was found for that fragment (i.e. the data is 
unexplained).

A few possible reasons no match was found are:

• Data is outside the scan range

• Missing peptide eluted in the dead volume

• It’s not in the protein due to mutations or modifications

2 Resolve any unexplained data or missing peptides. For example, you might 
want to redigest using an alternative enzyme.
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In this book

This guide has instructions 
for installing the Agilent 
Protein and Peptide Software. 
It then guides you through the 
steps of verifying the primary 
sequence of chicken lysozyme 
to illustrate how the software 
may be used.
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