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What is Agilent MassHunter StreamSelect Software?
What is Agilent MassHunter StreamSelect Software?

Agilent MassHunter StreamSelect Software provides the coordination and 
valve switching that is needed for the robust and efficient handling of LC/MS 
analyses using a Triple Quadrupole Mass Spectrometer and up to four Liquid 
Chromatography systems. MassHunter StreamSelect LC/MS Analysis offers 
higher productivity by maximizing the efficiency of LC/MS analysis with 
staggered, parallel, multi-LC channel flows into a single mass spectrometer.

What’s New in B.07.00

• You can have up to four streams in your system, so your system can run up 
to four times faster.

• You can select one of six contexts to use to perform different tasks.

• You can develop a unified method (for devices on all of the streams) when 
you use the Method Development context.

• You can run a sample or a worklist when you use the Method Development 
context.

• You can select one or more streams to use for a single sample run or a 
worklist.

• You can run an autotune or a manual tune in this program when you use 
the Tune context.

• You can select either to share all of the streams or to directly specify a 
stream when you run a batch (Private Stream or Shared Stream mode).

• You can specify a different profile to use with each batch. You can specify a 
different Data Acquisition method to use in each profile.

• You can run a different batch on each of the four streams.

• You can specify pre-batch and post-batch scripts in the profile.

• You can submit one script or a group of scripts to the Batch Queue.

• You can visualize the instrument better in the updated Instrument Status 
window.

• You can examine chromatograms from multiple data files in the Overlay 
Plot window.

• You can see the estimated batch completion time in the Batch Acquisition 
context.

• You can monitor Actuals for each stream in the Actuals window.

• You can overlap injections.
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Where to Find More Information
Where to Find More Information

For more information about the MassHunter StreamSelect Software, see the 
Agilent MassHunter StreamSelect Setup Guide (G2709-90005)

MassHunter StreamSelect Online Help

Refer to the online Help and tooltips available in these components of the 
MassHunter StreamSelect System:

• MassHunter StreamSelect Console 

• MassHunter StreamSelect Instrument Configuration 

MassHunter Data Acquisition Online Help

Refer to the MassHunter Data Acquisition for Triple Quadrupole LC/MS online 
Help for help on the Tune Window. This online Help can be opened from the 
Tune Window. The Data Acquisition online Help also contains additional 
information for the Method Editor, Sample Run, and Worklist windows.

MassHunter Data Acquisition Quick Start Guide

Refer to the Agilent 6400 Series Triple Quadrupole LC/MS System Quick 
Start Guide for more information about the MassHunter Data Acquisition 
program. You can open the Quick Start Guide from the MassHunter Data 
Acquisition online Help, or find the guide on the MassHunter Data Acquisition 
installation media.

Agilent Web Site

To view support information for MassHunter StreamSelect and other Agilent 
products, see:

http://www.chem.agilent.com
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MassHunter StreamSelect Console

Where to Find More Information
MassHunter StreamSelect Console

This program lets you submit, run, and monitor batches of samples for 
analysis.

To open the MassHunter StreamSelect Console

• Click Start > Agilent > MassHunter Workstation > StreamSelect.

• From the desktop folder Agilent MassHunter Workstation, click 
StreamSelect.

Tip The windows on the MassHunter StreamSelect Console can be resized, moved, 
or hidden to display only the information of interest. The layout can be saved; 
different layouts can be selected using the Layout controls on the toolbar or 
the menus. You can save a different layout for each Context.
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MassHunter StreamSelect Console

Six Contexts
Six Contexts

You select one of six contexts when you use StreamSelect. Each context has a 
different purpose, and each context has a different set of windows that are 
available. The toolbar and the menus also change depending on which context 
is selected. You select the Context in the toolbar.

Batch 

Acquisition 

Context

The Batch Acquisition context is used to submit batches and scripts to the 
Batch Queue. You can also run a Checktune from this context. These windows 
are available in this context:

• “Instrument Status Window” on page 7

• “Status Monitor Window” on page 7

• “Chromatogram Plot Window” on page 8

• “Batch Queue Window” on page 9

• “Actuals Window” on page 11

Overlay Plot 

Context

The Overlay Plot context is used to examine the real-time plot. You can 
overlay the LC and MS plots for up to the last 25 runs. This window is 
available in this context:

• “RTP Overlay Window” on page 12

Profile Editor 

Context

The Profile Editor context is used to edit a Profile. A Profile is a set of 
parameters that set how you want to do acquisitions. It includes the name of 
the acquisition method to use, warning and stopping limits for the pumps, 
data file naming rules, scripts to run before and after a batch, and the Batch 
Import Map File which determines the format that must be used when 
submitting a batch file. The Profile Editor Window has three different views. 
The following window is available in this context:

• “Profile Editor Window” on page 13

Figure 1 Six available Contexts in the toolbar
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MassHunter StreamSelect Console

Six Contexts
System Settings 

Context

The System Settings context is used to set system parameters. You choose 
whether the system is executed as a Shared Stream or as a Private Stream. 
You also specify a script to execute when the Batch Queue starts running, plus 
you can specify an error script and a sleep script. The following window is 
available in this context:

• “System Level Settings Window” on page 14

Method 

Development 

Context

The Method Development context is used to develop a data acquisition 
method. In this context, you can edit a method, run a sample, and run a 
worklist. You cannot switch to this context if the Batch Queue is running. The 
following windows are available in this context:

• “Chromatogram Plot Window” on page 8

• “Instrument Status Window” on page 7

• “Actuals Window” on page 11

• “Method Editor Window” on page 15

• “Sample Run Window” on page 16

• “Worklist Window” on page 17

Tune Context The Tune context is used to tune the instrument. You can run CheckTune and 
Autotune. You can also manually tune the instrument. The following windows 
are available in this context:

• “Tune Window” on page 18

• “Actuals Window” on page 11

• “Instrument Status Window” on page 7
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MassHunter StreamSelect Console

Instrument Status Window
Instrument Status Window

The Instrument Status window is visible in the Batch Acquisition context, the 
Method Development context, and the Tune context.

This window in the MassHunter StreamSelect Console shows the status of the 
instrument components of all streams, such as autosampler, pump, column 
compartment, mass spectrometer, and valve. The progress of the current 
sample run is also shown for each stream. 

Status Monitor Window

The Status Monitor window is only visible in the Batch Acquisition context.

This window shows the following information:

• actual values of key instrument parameters on the LC Status tab

• current counter values on the System Counters tab

Counters can be reset by right-clicking and clicking Reset from the shortcut 
menu.
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MassHunter StreamSelect Console

Chromatogram Plot Window
Chromatogram Plot Window

The Chromatogram Plot window is visible in the Batch Acquisition context 
and the Method Development context.

These windows in the MassHunter StreamSelect Console can be configured to 
plot data being acquired. The LC Chromatogram Plot windows are tabbed 
together by default. Each stream is shown in a different window. The initial 
plots are the Binary Pump pressure and Quat. Pump pressure. You can add or 
change the displayed plots in the Edit Signal Plot dialog box.

By default, the QQQ Chromatogram Plot contains the TIC for the mass 
spectrometer. You can add or change the displayed plots in the Edit Signal 
Plot dialog box which starts when you right-click the plot and click Change.
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MassHunter StreamSelect Console

Batch Queue Window
Batch Queue Window

The Batch Queue window is only visible in the Batch Acquisition context.

This window at the bottom of the MassHunter StreamSelect Console shows the 
following information:

Batch Status Pane

The pane at the top of the Batch Queue window shows status information for 
the Batch Queue, including the Workflow (Shared or Private stream), System 
state, the currently running sample, the System Message, and any approaching 
event like sleep timeout or the command requested by the user.

Batch Queue Tab

The Batch Queue tab shows the batches that have been submitted. Batches are 
run in the order in the table. You can change the order of the batches in the 
Batch Queue using the buttons in the toolbar.

Batch Queue Tab Toolbar

Toolbar Button Action

Move the selected batch to the top of the queue

Move the selected batch up one position in the queue

Move the selected batch down one position in the queue

Move the selected batch to the bottom of the queue
MassHunter StreamSelect Software Quick Start Guide 9



MassHunter StreamSelect Console

Batch Queue Window
Completed Batches Tab

The Completed Batches tab shows the batches that have been completed.

Completed Batches Tab Toolbar

Sample List Tab

To view information about the samples in a batch, highlight the batch of 
interest in the Batch Queue tab, and then click the View Sample List ( ) 
button. The Sample List tab opens and is labeled with the name of the selected 
batch. The Sample List tab has the following two panes of information:

• The Sample List pane shows the list of samples in the batch. 

Delete the selected batch or batches

Open the data folder for the selected batch

View a list of samples in the selected batch. See “Completed 
Batches Tab Toolbar” on page 10.

Toolbar Button Action

Toolbar Button Action

Open the folder for the selected batch in File Explorer.

Opens the Batch Log dialog box which shows information on 
events for the selected, completed batch.
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MassHunter StreamSelect Console

Actuals Window
• The Completed Samples List pane shows the samples that have been run 
and tells which stream they ran on, the methods used, and the data file 
names.

You can select a different batch to display in the Sample List tab. You can only 
view 4 batches at a time in Sample List tabs. If you try to open a fifth batch, 
the first batch you opened is automatically closed.

You can close the Sample List tab by clicking the X in the tab.

Actuals Window

The Actuals window is visible in the Batch Acquisition context, the Method 
Development context, and the Tune context.

The Actuals window contains two tables showing the current values of 
selected instrument parameters. The upper pane shows the values for 
different instrument parameters for different streams. The lower pane shows 
the values for instrument parameters that are the same for all streams.

You can customize the parameters that are displayed. You right-click in the 
window and click Actual Settings. The Actuals Selection dialog box is opened.
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MassHunter StreamSelect Console

RTP Overlay Window
RTP Overlay Window

The RTP Overlay window is only visible in the Overlay Plot context.

You can see real-time plots in this window along with the previous data files. 
You can either see all streams combined into one plot (Combined View tab) or 
streams separated into different tabs (Stream View tab). The plots that you 
can see include an MS trace (a total ion chromatogram or TIC) and LC traces 
(Binary Pump trace and Quat. Pump trace). In this window you have options 
to change which traces are displayed, which streams are displayed, and which 
data files are displayed.

On the right side of this window, you can place two additional panes. By 
default these panes are hidden at the edge of the window. When you click the 
label for the pane, the pane is visible. When you move the cursor away from 
this pane, the pane is hidden again. You can make these panes be visible 
continuously when you click on the pin in the title of the pane.

These panes allow you to customize which data files are displayed. You mark 
the data files in the Data file pane. You select how many data files to show in 
the Settings pane. You can also remove the data files from the list when you 
click Clear Data Files on the Settings pane.
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MassHunter StreamSelect Console

Profile Editor Window
Profile Editor Window

The Profile Editor window is only visible in the Profile Editor context.

The Profile Editor window lets you create profiles for each type of analysis 
done in your lab to simplify daily operation. Profiles are based on 
representative data collected with MassHunter Data Acquisition.

Profile Editor Views

You click the appropriate icon in the left pane to display the view of interest 
for the parameters you want to set. For more information, see MassHunter 
StreamSelect online Help.

Acquisition view This view lets you view and edit method information, such 
as selecting reference data files, setting the LC run time and MS start and stop 
times for the TIC, and setting pressure warning and stopping limits. You select 
the method to use in this view.

Data File Naming view This view lets you specify options for naming the data 
files for MassHunter StreamSelect. You can specify a location for the root data 
file directory, select names for data subdirectories, and components to make 
up the data file names.

System view This view lets you specify batch import settings, calibration 
settings, event actions, plate settings, and other parameters, such as Wait Time 
for Ready and free disk threshold values.

Calibrator Map dialog box

You click the + button in the Calibrator Map section of the System View to 
open the Calibrator Map dialog box.

This dialog box lets you create or edit calibrator maps. Calibrator maps are 
listed in the Calibrator Map section of the System view. A subset of the 
calibrator maps that have been defined for the system can be selected for use 
in a particular MassHunter StreamSelect profile. Calibrator Maps are global; 
changes that are made to a calibrator map affect all profiles that reference that 
calibrator map.
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MassHunter StreamSelect Console

System Level Settings Window
System Level Settings Window

The System Level Settings window is only visible in the System Settings 
context.

You set parameters that affect every user in this window. See the online Help 
for more information on this window. If you click Shared Stream, then 
samples from your batch are run on any available stream. If you click Private 
Stream, then all samples in your batch are run on the stream which you select 
when you submit the batch.
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MassHunter StreamSelect Console

Method Editor Window
Method Editor Window

The Method Editor window is only visible in the Method Development 
context.

This window allows you to create a method that consists of setpoints for the 
instrument. The tabs that appear in the window are only for devices that are 
currently configured on the system. The Method Editor window is dynamic. It 
allows you to both view and modify the current setpoints of the instrument. In 
addition, it has the Apply and Reset buttons. If a worklist is running, the 
setpoints change depending on which method is currently loaded on the 
instrument. You can get help on any tab in the Method Editor by pressing F1.
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MassHunter StreamSelect Console

Sample Run Window
Sample Run Window

The Sample Run window is only visible in the Method Development context.

You can submit a single sample when you use this window. You specify the 
data file name and path, the position of the sample, the stream, the injection 
volume, and the name. You can also modify some of the Additional 
Information.
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MassHunter StreamSelect Console

Worklist Window
Worklist Window

The Worklist window is only visible in the Method Development context.

The Worklist window allows you to create a list of samples to run. When you 
are developing a new method, you can create a worklist to run the method 
multiple times with different samples. You can use the menus to modify the 
worklist. You can also use the shortcut menus in the Worklist window. The 
shortcut menu changes depending on where you clicked on the table: a cell, a 
row, a column, or the upper left empty box.
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MassHunter StreamSelect Console

Tune Window
Tune Window

The Tune window is only visible in the Tune context.

You can run an Initial Autotune, an Autotune, or a Checktune from the Tune 
window. You can also manually tune the instrument from this window.
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Batch Sample Submission and Data Acquisition Method Setup

Before you start
Batch Sample Submission and Data Acquisition Method Setup

This section describes how to submit batches of samples in Agilent 
MassHunter StreamSelect Software, set up data acquisition methods for your 
analyses, and do a checktune on the instrument.

Before you start

• If methods have not yet been set up for your analysis, see “To set up 
methods for Data Acquisition” on page 22.

• Create or modify a profile for your analysis in the Profile context. 
MassHunter StreamSelect profiles can be developed for each type of 
analysis done in your lab to simplify daily operation. MassHunter 
StreamSelect profiles are based on representative data collected.  
See “Profile Editor Window” on page 13 for a description of the Profile 
Editor window. 

• Do a checktune on the instrument to verify performance as necessary. See 
“To do a checktune on the instrument” on page 26.

NOTE You specify the profile when you submit a batch.
MassHunter StreamSelect Software Quick Start Guide 19



Batch Sample Submission and Data Acquisition Method Setup

To submit batches
To submit batches

1 Open the MassHunter StreamSelect Console. See “To open the MassHunter 
StreamSelect Console” on page 4.

2 If necessary, select Batch Acquisition as the Context in the toolbar.
3 Click Submit Batch on the toolbar of the MassHunter StreamSelect 

Console. If you select Shared Stream in the System Settings context, then 
the Stream parameter is not included in this dialog box.

4 On the Submit Batch dialog box, enter the following information:

• Batch Name: Enter a name for the batch, which is used to determine 
where the batch folder is created based on Batch Naming settings.

• Submitter: The field is optional, but may be used in batch folder naming.

• Profile Path and Profile Name: Select a profile for the type of analysis 
that you are doing.

• Calibrator Map: Select a Calibrator map from the list. Calibrator maps 
are created and assigned to a profile in the MassHunter StreamSelect 
Profile Editor; see page 13 for more information. If you select Do not use 
Calibrator Map, then the samples in the Import File are either run on 
the stream which you selected (if you clicked Private Stream in the 
System Level Settings window) or run on alternating streams in the 
order they appear in the list (if you click Shared Stream in the System 
Level Settings window). For example on a Shared Stream system, 
sample line 1 runs on Stream 1, sample line 2 runs on Stream 2, and so 
on. If one stream shuts down during the run, then the remaining samples 
for that stream run or will run on a different stream.
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Batch Sample Submission and Data Acquisition Method Setup

To start, stop, and resume batches
• Import File: Select the file that contains the list of samples for the batch.

• Stream: If you select Private Stream, then you also need to select which 
Stream to use.

5 In the Plate Assignments Details table, assign a position in the 
autosampler to the plates in the Import File and Calibrator Map. By 
default, only plates that are not currently in use by any other batches can be 
assigned. See “System Level Settings Window” on page 14 to learn how to be 
allowed to use plates that are currently in use by other batches.

6 Click Finish.  
The batch appears in the Batch Queue window.

To start, stop, and resume batches

Use this procedure to manage the Batch Queue.

1 If the queue has stopped, restart it with one of the following options:

• Click Batch Queue > Start > Start Batch.

• Click Batch Queue > Start > Resume Batch.
2 If you need to reorder the batches in the queue, use the arrow buttons on 

the Batch Queue tab.

3 If you need to stop the batch before completion:

• Click Batch Queue > Stop> Stop Batch.

• Click Batch Queue > Stop> Stop after Current Sample.

• Click Batch Queue > Stop> Stop after Current Batch.
4 Monitor baseline and adjust plot in the Chromatogram Plot windows, as 

described in MassHunter StreamSelect Console online Help.
5 To view information about the samples in a batch, highlight the batch of 

interest, and then click the View Sample List button.

The sample information is shown in the Sample List tab of the Batch Queue 
window.
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Batch Sample Submission and Data Acquisition Method Setup

To set up methods for Data Acquisition
To set up methods for Data Acquisition

You use the Method Development context to set acquisition method 
parameters. If the Batch Queue is running, you cannot select the Method 
Development context.

1 Select Method Development for the Context.
2 Click the Method Editor window.
3 On the Valve tab in the Method Editor window:

• For Position, click Use current valve position.

• For Position switch at end of run, click Do not switch.

Note that tab names can be customized; your system may have different labels.
4 Set the Stoptime for devices in the Method Editor window:

• On the Pump and QQQ tabs, set the Stoptime to the same values. 

• For all other devices, such as TCC, set the Stoptime to the default value 
of As Injector/No Limit.
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Batch Sample Submission and Data Acquisition Method Setup

To set up methods for Data Acquisition
5 Set cycle parameters:

a On the HTS/HTC tab in the Method Editor window, select a cycle from 
the Available Cycles list.

b Review the other parameters on this tab.

6 Set additional method parameters on the Column Comp. tab in the Method 
Editor window.

For information on setting Acquisition method parameters, see the online 
Help for MassHunter Workstation Data Acquisition software.

7 Set other LC parameters.
8 Set the parameters on the QQQ tab.
9 Set the parameters on the DA tab.
10 Set the parameters on the Properties tab.
11 Save the method.
12 Set up a worklist to verify the method for your analysis as explained in the 

next section.
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Batch Sample Submission and Data Acquisition Method Setup

To verify an acquisition method using a single sample
To verify an acquisition method using a single sample

You use the Method Development context to run a single sample as follows.

This task helps you test the new method you created in “To set up methods for 
Data Acquisition” on page 22. 

For more information on running samples, see the online Help for MassHunter 
Workstation Data Acquisition software.

1 Select Method Development as the Context from the toolbar.
2 Click the Sample Run tab. If this tab is not visible, click View > Sample 

Run.

3 Enter the following information:

• Name (Sample)

• Position

• Stream 

• Injection volume

• Name (Data File)
4 If necessary, modify other parameters under Additional Information.
5 Click Sample > Run or press F5.
6 (optional) Examine the real-time plots in the Chromatogram Plots window 

or switch to the Overlay Plot context and view the real-time plots in that 
context.
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Batch Sample Submission and Data Acquisition Method Setup

To verify an acquisition method using a worklist
To verify an acquisition method using a worklist

You use the Method Development context to set up a worklist as follows. 

You can test the new method you created in “To set up methods for Data 
Acquisition” on page 22 by creating a worklist. For more information on 
setting up worklists, see the online Help for MassHunter Workstation Data 
Acquisition software.

1 If necessary, select Method Development for the Context.
2 Set up a worklist as follows. The worklist runs your sample of interest on 

two LC streams.

a Add the first sample to the worklist:

• Click Add Sample from the Worklist menu. A new sample row is added to 
the Worklist table. 

• Select a Stream to use for this sample in the Worklist. You select the 
Stream in the Stream column in the worklist table.

• Fill out the information for this sample, using the Method you developed 
in the previous steps of this procedure.

b Add additional sample rows to the Worklist table:

• Click Add Sample from the Worklist menu. A new sample row is added to 
the Worklist table. 

• Select a Stream to use for this row in the Worklist

• Fill out the information for this second sample, using the same Sample 
Position and Method as used for the first sample.

c Click Worklist Run Parameters from the Worklist menu to set 
parameters on the Worklist Run Parameters dialog box.

d (optional) Save the worklist.
3 Place the sample in the proper location if it is not already there.
4 Run the worklist and evaluate the results.

a Click Worklist > Run.

b When the analyses are completed, compare the results in MassHunter 
Qualitative Analysis to make sure the method gives the expected results 
for all LC streams. 

c Modify the method parameters if necessary.

d Save the method if you make any changes.
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Batch Sample Submission and Data Acquisition Method Setup

To do a checktune on the instrument
You are now ready to use the Batch Queue. See “To submit batches” on 
page 20.

To do a checktune on the instrument

Run the Checktune procedure as needed to verify the performance of the 
Triple Quadrupole. Checktune checks the mass axis tolerance and the peak 
width for three different peak widths and displays the result. You can also run 
a Checktune from the Tune context. See “Tune Window” on page 18.

1 Open the MassHunter StreamSelect Console. See “To open the MassHunter 
StreamSelect Console” on page 4.

2 If the mass spectrometer is in standby, right-click the QQQ device pane in 
the Instrument Status window and click On to turn it on.

3 Click the Checktune icon on the toolbar.

4 On the Checktune dialog box:

a Set the Polarity to use during Checktune:

• Positive

• Negative

• Both (positive and negative polarities) 

b Click Checktune.

When you start Checktune, the Triple Quadrupole may go to a “Not Ready” 
state. Checktune parameters take time to stabilize. Checktune begins 
automatically when the Triple Quadrupole is ready and can take up to 15 
minutes to run.
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Batch Sample Submission and Data Acquisition Method Setup

To do a checktune on the instrument
When Checktune is finished:

• If the Checktune passes, a message is displayed stating that it passed. 

• If the Checktune does not pass, a message is displayed that says that 
Autotune is recommended. 

• A Checktune Report appears in the Print Preview dialog box.
5 If the Checktune does not pass, select the Tune context, and run an 

Autotune on the QQQ.

NOTE • The system automatically runs the correct checktune, depending on whether a 
standard tune file or a fast scan tune file is loaded.

• The Checktune for a Fast Scan autotune file only checks the MS2 operation and reports 
only the MS2 operation.
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To do a checktune on the instrument
Reference

In addition to the MassHunter StreamSelect Acquisition Console, the 
MassHunter StreamSelect software includes:

• “MassHunter StreamSelect Instrument Configuration” on page 29, which 
lets you configure instruments for MassHunter StreamSelect. For more 
information, see the MassHunter StreamSelect Setup Guide.

Agilent MassHunter Workstation Data Acquisition software

Several of the windows in the Method Development context are very similar to 
windows in the MassHunter Data Acquisition program. The Tune window in 
the Tune context is very similar to the Tune window in MassHunter Data 
Acquisition. You can also refer to the documentation for the MassHunter Data 
Acquisition program for additional help.

Agilent MassHunter Workstation Qualitative Analysis software

You do the following in the MassHunter Qualitative Analysis program if you 
want to identify which stream was used to acquire a data file:

1 Open the MassHunter Qualitative Analysis program.

2 Open the data file.

3 Open the Sample Information window. 

The stream is shown in the Stream Name information.

Agilent MassHunter Workstation Quantitative Analysis software

You do the following in the MassHunter Quantitative Analysis program if you 
want to identify which stream was used to acquire a data file:

1 Open the MassHunter Quantitative Analysis program.

2 Create a batch. Select the data file to be part of the batch.

3 Add the Sample Group column, which is part of the Sample columns.

4 Click View > Toolbars > Filtering to display the filtering toolbar.

5 Filter which streams are displayed in the table.
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MassHunter StreamSelect Instrument Configuration
MassHunter StreamSelect Instrument Configuration

This dialog box lets you configure instruments for MassHunter StreamSelect. 
For more information, see the MassHunter StreamSelect Setup Guide.

To display the MassHunter StreamSelect Instrument Configuration window, 
do one of the following: 

• Click Start > Agilent > MassHunter Workstation> Acq Tools > Instrument 
Configuration.

• From the desktop folder Agilent MassHunter Workstation, open the Acq 
Tools folder and click Instrument Configuration.
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